Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA: Agregar videos de Wipido

Agregar videos de Wipido 8 años 10 meses ago #18404

  • gimenezadrian
  • Avatar de gimenezadrian
  • Offline
  • Visitante
  • Mensajes: 19
  • Gracias recibidas 1
  • Karma: 0
Hola, me gustaria saber como agregar videos de Wipido www.wipido.com/ en Kunena 1.6.x

Se que hay que modificar el php pero hasta ahi nomas. Gracias!
El administrador ha desactivado la escritura pública.

Re: Agregar videos de Wipido 8 años 10 meses ago #18421

  • JoniJnm
  • Avatar de JoniJnm
  • Offline
  • Administrador
  • Mensajes: 4579
  • Gracias recibidas 544
  • Karma: 160
Hola,

Abre el archivo com_kunena/lib/kunena.parser.php
Busca:
'youtube' => array ('flash', 425, 355, 0, 0, 'http://www.youtube.com/v/%vcode%?fs=1&hd=0&rel=1', '\/watch\?v=([\w\-]*)' , array (array (6, 'wmode', 'transparent' ) ) ),
 
//añade después
 
'wipido' => array ('flash', 480, 320, 0, 0, 'http://embed.minoto-video.com/90/%vcode%', 'http:\/\/www.wipido.com\/video\/\([\w]+)' , array (array (6, 'wmode', 'transparent' ) ) ),

Después, para poner el vídeo:
{video type=wipido}CODIGO{/video}

Con corchetes en vez de llaves. El código es lo que viene en la url del vídeo
Última Edición: 8 años 10 meses ago por JoniJnm.
El administrador ha desactivado la escritura pública.

Re: Agregar videos de Wipido 8 años 10 meses ago #18426

  • gimenezadrian
  • Avatar de gimenezadrian
  • Offline
  • Visitante
  • Mensajes: 19
  • Gracias recibidas 1
  • Karma: 0
Perfecto, ahora veo si se puede agregar en la lista de Proveedor, en caso de no poder por ahí te este molestando nuevamente. :lol:

EDIT: No funciona, el video no se reproduce y si pongo otro id me dice video no encontrado (hay que tomar el codigo desde el codigo de embebido no de la url) :(

Creo que se porque no se reproduce, el codigo que se genera es este:
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab" width="480" height="320"><param name="movie" value="http://embed.minoto-video.com/90/yeX7LuT3mM5x"><param name="quality" value="high"><param name="allowFullScreen" value="true"><param name="allowScriptAccess" value="never"><param name="wmode" value="transparent"><embed src="http://embed.minoto-video.com/90/yeX7LuT3mM5x" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" quality="high" allowfullscreen="true" allowscriptaccess="never" width="480" height="320" wmode="transparent"></object>

y deberia quedar sin los quality y con allowScriptAccess en always
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab" width="480" height="320"><param name="movie" value="http://embed.minoto-video.com/90/yeX7LuT3mM5x"><param name="allowFullScreen" value="true"><param name="allowScriptAccess" value="always"><param name="wmode" value="transparent"><embed src="http://embed.minoto-video.com/90/yeX7LuT3mM5x" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" allowfullscreen="true" allowscriptaccess="always" width="480" height="320" wmode="transparent"></object>

Lo "arregle" usando en vez de 'flash' uno nuevo 'wipido' agregando esto:
case 'wipido' :
					$vid_par1 = array (array (1, 'classid', 'clsid:d27cdb6e-ae6d-11cf-96b8-444553540000' ), array (1, 'codebase', 'http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab' ), array (2, 'movie', $vid_source ), array (4, 'src', $vid_source ), array (4, 'type', 'application/x-shockwave-flash' ), array (4, 'pluginspage', 'http://www.macromedia.com/go/getflashplayer' ), array (6, 'allowFullScreen', 'true' ), array (6, 'allowScriptAccess', 'always' ), array (5, 'width', $vid_width ), array (5, 'height', $vid_height ) );
					$vid_allowpar = array ('flashvars', 'wmode', 'bgcolor' );
						break;

EDIT: Igual lo veo muy complicado asi, capaz paso algo por alto.
Última Edición: 8 años 10 meses ago por gimenezadrian.
El administrador ha desactivado la escritura pública.

Re: Agregar videos de Wipido 8 años 10 meses ago #18438

  • JoniJnm
  • Avatar de JoniJnm
  • Offline
  • Administrador
  • Mensajes: 4579
  • Gracias recibidas 544
  • Karma: 160
Yo aquí no tengo eso, y mira, se ve el vídeo (usando firefox).

Has probado a poner:
'wipido' => array ('flash', 480, 320, 0, 0, 'http://embed.minoto-video.com/90/%vcode%', 'http:\/\/www.wipido.com\/video\/\([\w]+)' , array (array (6, 'wmode', 'transparent' ),array (6, 'allowScriptAccess', 'always' ) ) )

No sé si funcionará...

Lo que te decía del servidor, quizá tengas que coger del código embed el servidor donde está (90/) y ponerlo como código:
{video type=wipido}90/yeX7LuT3mM5x{/video}
El administrador ha desactivado la escritura pública.

Re: Agregar videos de Wipido 8 años 10 meses ago #18440

  • gimenezadrian
  • Avatar de gimenezadrian
  • Offline
  • Visitante
  • Mensajes: 19
  • Gracias recibidas 1
  • Karma: 0
Voy a probar, por el momento uso el método de permitir HTML y que directamente pongan el código embebido entre [/html]

Gracias por el tiempo empleado en la consulta. :)

EDIT: Funciona perfecto con el ultimo código que pusiste, tengo que aprender esto porque termine dando toda la vuelta a algo que se resolvía en una sola linea.

Te hago una consulta referida, no me toma el tamaño del video como si lo hace en este foro a mi todos los que meto con el tag me los pone a 405x320 quedando muy cuadrado (4:3) ¿alguna idea? No solo este de Wipido sino todos como los de Youtube, Gametrailers, siempre usando la etiqueta [videos] EDIT: Solucione el tamaño de los videos tocando este codigo: [code type=php]// --- config start ------------ $vid_minwidth = 200; $vid_minheight = 44; // min. display size $vid_maxwidth = 720; $vid_maxheight = 480; // max. display size //$vid_maxwidth = ( int ) (($kunena_config->rtewidth * 9) / 10); // Max 90% of text width //$vid_maxheight = 720; // max. display size $vid_sizemax = 300; // max. display zoom in percent // --- config end --------------[/code][video] me los pone a 405x320 quedando muy cuadrado (4:3) ¿alguna idea? No solo este de Wipido sino todos como los de Youtube, Gametrailers, siempre usando la etiqueta [videos]

EDIT: Solucione el tamaño de los videos tocando este codigo:
// --- config start ------------
 
$vid_minwidth = 200;
$vid_minheight = 44; // min. display size
 
$vid_maxwidth = 720; $vid_maxheight = 480; // max. display size
 
//$vid_maxwidth = ( int ) (($kunena_config->rtewidth * 9) / 10); // Max 90% of text width
//$vid_maxheight = 720; // max. display size
 
$vid_sizemax = 300; // max. display zoom in percent
 
// --- config end --------------
Última Edición: 8 años 10 meses ago por gimenezadrian.
El administrador ha desactivado la escritura pública.
Tiempo de carga de la página: 0.172 segundos