Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA: Paginas en blanco en administrador

Paginas en blanco en administrador 9 años 2 meses ago #17142

  • Desdemona
  • Avatar de Desdemona
  • Offline
  • Visitante
  • Mensajes: 2
  • Karma: 0
Dejenme decirles, antes que nada, que toda es comunidad ha sido mi "soporte" constante en todos los problemas que pudieron surgir cuando comence a administrar Joomla asi que ante todo muchas gracias! sobre todo a Joni que es un Maestro!

Hoy, sin embargo, tengo un problema (muy grave para mi) y no he encontrado ninguna solucion en ninguna parte de la web: Mi sitio se visualiza perfectamente en el frontend, todas las funcionalidades del sitio estan en perfecto estado el problema esta en el back. Alli puedo loguearme sin dificultad, y veo el panel de control sin problemas. Sin embargo cuando quiero ingresar a cualquier item del menu (gestor de modulos, templates, contenido o cualquier componente la pagina se queda en blanco completamente. No me visualiza ningun error, simplemente queda en blanco. Hasta el dia de ayer pude trabajar sin problemas y de hecho pude crear un nuevo usuario y darles privilegios de superadministrador. (Acualmente tengo 3 usuarios con estos privilegios, lo cuento por las dudas tenga relacion con el problema)
Les cuento lo que hice hasta ahora:
  • Pedi a mi proveedor de hosting que me activen el "display error" en php.ini pero me responden que no es posible
  • Reemplace todos los archivos por FTP de TODO el sitio con el pack Joomla completo
  • Revise .htacces y configuration.php y todo esta en orden

Tengo Joomla 1.5.20. ¿Me pueden ayudar?
Se que si, asi que me abandono a sus conocimientos jajaja!

Muchas Gracias
Desdemona
El administrador ha desactivado la escritura pública.

Re: Paginas en blanco en administrador 9 años 2 meses ago #17174

  • JoniJnm
  • Avatar de JoniJnm
  • Offline
  • Administrador
  • Mensajes: 4579
  • Gracias recibidas 544
  • Karma: 160
Hola,

Yo diría que es un plugin de sistema, que tiene un error grave y pues se muestra la página en blanco.

Puedes probar a poner :
error_reporting(E_ALL);

Antes de
JPluginHelper::importPlugin('system');

En el archivo index.php de la administración de Joomla. Si sigue viéndose en blanco ponlo antes de cada instrucción del index.php que en alguna estará el error xD

Puedes probar a despublicar los plugins de systema desde phpmyadmin, a ver si es por alguno.

Al index de la administración de Joomla si puedes entrar?
El administrador ha desactivado la escritura pública.

Re: Paginas en blanco en administrador 9 años 2 meses ago #17185

  • Desdemona
  • Avatar de Desdemona
  • Offline
  • Visitante
  • Mensajes: 2
  • Karma: 0
Hola Joni!
Te cuento: finalmente recurri a mi proveedor de hosting para que me buscaran un backup del sitio (el mio databa de fines de agosto) y me consiguieron y restablecieron un back practicamente del instante anterior al error, con lo cual los efectos negativos del problema fueron minimos.
Aunque no lo usare para este sitio, tu consejo es super util y seguramente lo usaré en otros sitios en producción.
Para sumar algunos datos (por las dudas a alguien le pase algo parecido) yo podia ingresar solo al panel de control del administrator, cualquier otra pagina (del tipo .../administrator/index.php?option=com_xx) quedaba en blanco. Estuve probando habilitar/deshabilitar plugins desde phpMyadmin pero solo lo hice con algunos por lo que no puedo tomarlo como referencia.
Estaria muy bueno que si alguien tiene este problema siga este hilo ya que es un error muy comun y "la enciclopedia online
JoniJnm" podria ser punto de referencia.
Gracias!
El administrador ha desactivado la escritura pública.

Re: Paginas en blanco en administrador 9 años 2 semanas ago #17716

Hola, como estan? me pasa algo muy similar...

El problema mio, que creo que ya lo habia posteado previamente, pero no recuerdo si fue en un foro de esta web u otra, de todas maneras no obtuve respuestas. Buscando en google, encontre algunas respuestas mas o menos que se asemejaban con casos similares, pero con mi ingles basico pude darme cuenta que al final, aunque se trataba del mismo problema, eran casos diferentes, ya que hablaban de componentes y/o modulos y/o plugins que podrian haber causado lo que yo expongo en el titulo de mi post pero que yo no tengo instalados.

Les comento que basicamente no puedo ver la informacion del sistema de mi joomla, dentro del menu Ayuda, donde me muestra los directorios que usa joomla y demas. La pagina se queda colgada en blanco y no me muestra error alguno. Es rarisimo, hace rato que tengo ese error y aun no he podido dar con su solucion.

La pagina se queda colgada en www.midominio.com/administrator/index.ph...min&task=sysinfo y se queda ahi y no pasa mas nada. Acabo de actualizar a la ultima version vigente al dia de hoy, la 1.5.22 y aun asi sigo manifestando ese conflicto.

Alguien podria ayudarme?


Muchas gracias y saludos!
El administrador ha desactivado la escritura pública.

Re: Paginas en blanco en administrador 9 años 2 semanas ago #17733

  • JoniJnm
  • Avatar de JoniJnm
  • Offline
  • Administrador
  • Mensajes: 4579
  • Gracias recibidas 544
  • Karma: 160
Cuando una página se queda en blanco es por un error de php, no muestra el error por seguridad (si algún hacker viera el error podría aprovecharse de él), pero a la administración no pueden entrar sin login, así que no pasaría nada si lo mostrara.

Yo te recomiendo que hagas lo siguiente:
1. Hacer un backup de la base de datos
2. Apuntar en algún lado los plugins de tipo "System" que tienes publicados
3. Despublicar todos
4. Probar si funciona bien la página
5 Si funciona bien, es por algún puglin de los anteriores, así que sólo tienes que ir publicándolos poco a poco e ir probando para saber cuál da el error. FIN
6. Si no da error, prueba a despublicar todos los plugins e intenta hacer lo mismo que antes.

También puedes probar lo del error_reporting(E_ALL); que pongo arriba de este post. Es muy probable que escribiéndolo en cada empiece de linea del index.php de la administración te diga cuál es el error en vez de salir la página en blanco (si sigue en blanco yo diría que es porque algún archivo .php está mal formado)
El administrador ha desactivado la escritura pública.

Re: Paginas en blanco en administrador [Solucionado] 9 años 2 semanas ago #17755

Amigo, lo pude solucionar!

1-Hice el backup.
2-Probe en local y me mostraba errores, tales como:

Fatal error: Class 'TOOLBAR_admin' not found in E:\xampp\htdocs\htdocs\administrator\components\com_admin\toolbar.admin.php on line 23
Call Stack
# Time Memory Function Location
1 0.0037 353680 {main}( ) ..\index.php:0
2 0.4408 5356216 JAdministrator->dispatch( ) ..\index.php:67
3 0.4510 5706216 JComponentHelper->renderComponent( ) ..\application.php:136
4 0.6755 6027400 include_once( 'E:\xampp\htdocs\htdocs\administrator\components\com_admin\toolbar.admin.php' ) ..\helper.php:174

3-Supuse que ese seria el error que tu me habias dicho que no se me mostraria por seguridad y que no se aproveche alguien de esa vulnerabilidad, aunque no se si asi llamarla.
4-Baje un sitio que me funciona bien la parte de Informacion del sistema. Al probarlo en local, funcionaba bien tambien.
5-Por lo tanto, el error estaba en el sitio que no me funcionaba, no era ningun problema de servidor, ni de plugin, ni modulo, ni componente ni nada, porque los dos sitios usan practicamente los mismos, y aparte estan a la misma version actualizados.
6-Para solucionarlo, les comento como hice por si a alguno le ocurre lo mismo o algo parecido alguna vez, simplemente lo que hice fue, desde el sitio que me funcionaba bien la parte de "Informacion del Sistema", baje toda la carpeta com_admin que se encuentra en el directorio Carpeta Raiz/administrator/components/ y la copie al sitio donde estaba defectuoso y salio todo perfecto, ahora tengo joomla actualizado y puedo ver la info del sistema sin problemas :):):):)

Saludos!! :) :P
El administrador ha desactivado la escritura pública.
Tiempo de carga de la página: 0.334 segundos