Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA: Configurar SEF en Joomla! 1.5?

Configurar SEF en Joomla! 1.5? 11 años 7 meses ago #10007

  • DimeOscuro
  • Avatar de DimeOscuro
  • Offline
  • Ayudante
  • Mensajes: 131
  • Gracias recibidas 8
  • Karma: 5
Buenas a todos! Tengo un problema al configurar las SEF que trae por defecto Joomla!1.5.8

El tema es el siguiente, no quiero usar ningún componente como sh404SEF por que a la larga consume mucho recurso con llamados continuos a la base de datos y como pienso hacer crecer mi comunidad quiero hacer las cosas bien desde el comienzo.

Entonces, prefiero acostumbrar a los usuarios (y a google) a las url de mi sitio a luego tener que sacarlas.

El problema es que cuando activo las SEF (y el Apache mod_rewrite así como el sufijo html) la pagina de inicio me funciona, las demás me tiran error 404.

Me renombra las direcciones de una forma amigable pero que me los devuelve como enlaces rotos. Entonces un ejemplo:

En lugar de:

vivirmusica.com.ar/index.php?option=com_kunena&Itemid=2

Me devuelve:

vivirmusica.com.ar/foros-mainmenu-2.html

Pero con error 404.

Los enlaces internos me funcionan, pero no son muy amigables las url como debería ser según dicen, ya que este es un ejemplo de la url amigable de un post (fireboard, desde luego):

vivirmusica.com.ar/component/fireboard/?func=view&catid=9&id=79#79

en lugar de:

vivirmusica.com.ar/index.php?option=com_kunena&Itemid=2&func=view&catid=9&id=79#79

A saber:

Si, renombre el .htacces.

Si, limpie la Cache.

Espero alguien me pueda orientar a configurar las SEF de Joomla! O de algun manual, ya que busque por todos lados y nada util.

Saludos!

PD: el tiempo de sesión en estos foros es muy corto jajajajaja. Siempre me saca antes de terminar de escribir :P
Última Edición: 10 años 7 meses ago por JoniJnm.
El administrador ha desactivado la escritura pública.

Re: Configurar SEF en Joomla! 1.5.8? 11 años 7 meses ago #10016

  • JoniJnm
  • Avatar de JoniJnm
  • Offline
  • Administrador
  • Mensajes: 4579
  • Gracias recibidas 544
  • Karma: 160
hola, qué enlaces SEO más raros te salen,

Tienes Joomla! instalada en la raíz?

Has probado a quitar la almuadilla (#) de:
# rewirtebase /

?

El enlace del foro debería ser: web/[alias-de-fireboard].html?func=ect
Si no te sale así, ve al menú donde tengas el enlace al componente, edítalo, elige "enlace a fireboard" y guarda
El administrador ha desactivado la escritura pública.

Re: Configurar SEF en Joomla! 1.5.8? 11 años 7 meses ago #10018

  • DimeOscuro
  • Avatar de DimeOscuro
  • Offline
  • Ayudante
  • Mensajes: 131
  • Gracias recibidas 8
  • Karma: 5
Bien, no hubo exito.

Tengo a Joomla instalado desde raiz, asi es.

Intente quitando la almuadilla # y el resultado fue el mismo.

Renombre los alias, re edite los enlaces... nada. Claramente pareciera ser un error del mod_mainmenu, por que los demás enlaces funcionan.

Pero tengo 2 dudas ahora:

Tengo que agregar algún código especial en el .htaccess?? por que cuando desactivo el Apache mod_rewrite corren los enlaces, pero no carga el template.

De ser positiva la pregunta anterior, alguien lo conoce? :P

Saludos!
El administrador ha desactivado la escritura pública.

Re: Configurar SEF en Joomla! 1.5.8? 11 años 7 meses ago #10019

  • Pepillo
  • Avatar de Pepillo
  • Offline
  • Observador
  • Mensajes: 21
  • Gracias recibidas 1
  • Karma: 2
Siento entrometer, y más cuando no es para ayudar, sino igual para liar más....

DimeOscuro habla de SEF, y Joomla 1.5.8 lo que tiene de "fábrica" es SEO, no hay diferencia Joni?

Igual es ese el problema, que el SEO no te trabaja bien, y tendrás que probar a instlar una extensión aparte de SEF.

Un saludo ;)
El administrador ha desactivado la escritura pública.

Re: Configurar SEF en Joomla! 1.5.8? 11 años 7 meses ago #10021

  • DimeOscuro
  • Avatar de DimeOscuro
  • Offline
  • Ayudante
  • Mensajes: 131
  • Gracias recibidas 8
  • Karma: 5
Si, yo la mezcle toda cuando mencione los SEF del componente, pero se entendió de que hablaba.

Claramente me refiero a las URLs amigables para motores de búsqueda que trae joomla! por defecto.

Saludos!.
El administrador ha desactivado la escritura pública.

Re: Configurar SEF en Joomla! 1.5.8? 11 años 7 meses ago #10022

  • JoniJnm
  • Avatar de JoniJnm
  • Offline
  • Administrador
  • Mensajes: 4579
  • Gracias recibidas 544
  • Karma: 160
Mira, te paso el .htaccess que tengo yo, si quieres cópia y pega.
Options +FollowSymLinks

RewriteEngine On

RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
RewriteRule ^(.*)$ index.php [F,L]

RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

Puede que el servidor de tu Web no permita mod rewrite, para probarlo, escribe abajo del todo:
Redirect 301 /inicio.html http://www.tu_web.es/

Después ve a tu_web.com/inicio.html a ver si te redirecciona
Última Edición: 11 años 7 meses ago por JoniJnm.
El administrador ha desactivado la escritura pública.
Los siguientes usuarios han agradecido: JoniJnm

Re: Configurar SEF en Joomla! 1.5.8? 11 años 7 meses ago #10030

  • DimeOscuro
  • Avatar de DimeOscuro
  • Offline
  • Ayudante
  • Mensajes: 131
  • Gracias recibidas 8
  • Karma: 5
Dios!!!!!! sin duda sos el Puto Amo!

Funciono.

A tener en cuenta, las SEO (SEF) de joomla si trabajan con el .htaccess

Hay que trabajarlos a la antigua (como con viejos componentes).

Las SEO raras que me tiraba eran por los alias de cada componente.

Mi error estaba en una linea del .htaccess que tuve que adaptar para pasarla del componente para SEF anterior al de Joomla!.

Solo tuve 3 problemas:

El componente linX (de enlaces reciprocos) no lo toma.
El componente Uiddem (mensajeria privada) No lo toma.
El componente Sitemap no carga el template.



Mil gracias una vez mas.

Para lo que necesites, a tu disposición!
Última Edición: 11 años 7 meses ago por DimeOscuro.
El administrador ha desactivado la escritura pública.

Re: Configurar SEF en Joomla! 1.5.8? 11 años 7 meses ago #10031

  • DimeOscuro
  • Avatar de DimeOscuro
  • Offline
  • Ayudante
  • Mensajes: 131
  • Gracias recibidas 8
  • Karma: 5
Solucionados los problemas anteriores.

El de Uiddem y LinX solo tenia que limpiar la cache de joomla!.

Ahora, cuando activen las SEO, el componente com_jevents les va a tirar siempre el siguiente error (que tira el sitio enterio)

Fatal error: Class 'JEV_Helper' not found in htdocs/components/com_events/router.php on line 42

Se soluciona de la siguiente forma:

Justo debajo de la linea 12 del router.php agregan lo siguiente:
include_once(JPATH_SITE . '/components/com_events/libraries/helper.php');

Con eso problema solucionado.

Saludos!
El administrador ha desactivado la escritura pública.

Re: Configurar SEF en Joomla! 1.5.8? 11 años 5 meses ago #11040

  • yeite
  • Avatar de yeite
  • Offline
  • Visitante
  • Mensajes: 3
  • Karma: 0
Yo consegui hacer andar las direcciones amigables instalando sh404SEF. LO curioso es que no puedo quitar el index.php
Ya intente modificando el .htaccess, por el que publicaste jonijnm, pero así no consigo que funcione. Desaparece el index.php y automaticamente larga el error 404 (The page cannot be found)

Pregunte en mi hosting si tenia activado apache mod_rewrite y me dijeron que si, que esta activado.

Que otras opciones puedo intentar? muchas gracias
El administrador ha desactivado la escritura pública.
Tiempo de carga de la página: 0.294 segundos